Page MenuHomePhabricator

custom SOF master issues
Closed, ResolvedPublic

Description

Custom layout SOF master fader controls mixer, but doesn't react to changes on the mixer.

Custom layout SOF master fader mute doesn't operate or display changing status. It does display the status correctly when first selected.

Custom layout SOF master fader disappears when directly selecting another mix bus without first deselecting or selecting Main.

I haven't tested these on X32, but the issues are present on both XR and Qu.
Main master fader in same location works correctly. These are SOF issues.

Should I break reports like this out into multiples?

Event Timeline

nottooloud created this object in space S1 Public.

Ah, forgot one.

Custom layout SOF master fader meters don't update except when first opened.

david added a subscriber: david.Jul 25 2018, 6:58 AM

How did you assign the channel strip? just assigned it to the "sof master" source?

Visibility Always Always
Add Action
Ch
Active
Dynamic channel
Bus master
Use Sof

Ah "Use SoF" must be disabled when using the bus master. Otherwise it hides ifself

One down without even opening a compiler. Bravo!

david added a comment.Jul 25 2018, 1:53 PM

Good :) But I'll change the logic so the "SoF Enable" doesn't do anything when the "Busmaster" is selected.

david added a comment.Jul 25 2018, 1:53 PM

Good :) But I'll change the logic so the "SoF Enable" doesn't do anything when the "Busmaster" is selected.

I just checked with "Use Sof" disabled and I could not reproduce the issues so far

Oh, of course. I didn't think to check the other symptoms after turning off Use Sof. Everything works. You win again!

What does Use Sof do?

david changed the task status from Open to Confirmed.Jul 26 2018, 2:34 PM

When enabled this channel strip will follow the sends on fader mode (if enabled).
If not, you will always have the LR mix assigned to that fader.
This can be useful when working with monitors when you want fixed Bus channels which do not follow the sends of fader of the matrix

david closed this task as Resolved.Jul 27 2018, 7:57 AM
david claimed this task.