Page MenuHomePhabricator

Snapshot Next-button shows selected snapshot, Prev-button shows Prev snapshot
Closed, ResolvedPublic

Description

The Next and Go+Next show the name of the selected snapshot, and not the 'next' snapshot. The Prev and Go+Prev show the 'prev' snapshot.
I have an example with 3 snapshots:
1 is current 1 is selected:


1 is current 2 is selected:

2 is current 2 is selected:

2 is current 3 is selected:

3 is current 3 is selected:

As you can see, the Next-buttons show the same as the Go-button, while the Prev-buttons show the actual prev-snapshot.

Details

Commits
Restricted Diffusion Commit
Restricted Diffusion Commit
Restricted Diffusion Commit

Event Timeline

Martin1704 created this object in space S1 Public.
david changed the task status from Open to Confirmed.Nov 7 2018, 8:24 PM
david added a subscriber: david.Nov 8 2018, 1:02 PM

The actual issue is that the selected scene does not increase when loading a snapshot.
After fixing this issue the labels are correctly shown

david closed this task as Resolved by committing Restricted Diffusion Commit.Nov 8 2018, 1:08 PM
david added a commit: Restricted Diffusion Commit.
Martin1704 reopened this task as Open.Nov 12 2018, 9:15 PM

It still does not work as expected, the Go-button just goes to the next and not the selected. In my mind you have the current selected snapshot, prev show the previous, next show the next. And the Go should then make the selected snapshot permanent. The Go+Next immediate goes to the next and same with the Go+Prev. It just is very messed up, can't make out what happens.
And if you do a next on the last snapshot the app completely crashes.

david added a comment.EditedNov 13 2018, 2:44 PM

Yes it was indeed a bit off.
Now it behaves correctly:

  • Go loads the selected item
  • Next shows the next item
  • Prev shows the previous item
  • Go+Next loads the snapshot and increases the selected position
  • Go+Prev loads the snapshot and decreases the selected position
david closed this task as Resolved by committing Restricted Diffusion Commit.Nov 13 2018, 2:47 PM
david added a commit: Restricted Diffusion Commit.
Martin1704 reopened this task as Open.Nov 19 2018, 10:52 PM

Working much better now, but the Go-button is still going forward as soon as you press it. The Go+Prev seems to be going to the current, or something like that. Go+Next also works a bit strange.

david closed this task as Resolved by committing Restricted Diffusion Commit.Nov 20 2018, 5:05 PM
david added a commit: Restricted Diffusion Commit.