Page MenuHomePhabricator

Autosave always enabled
Closed, ResolvedPublic

Description

app settings don't always load properly. When I'm on layout/layer "A" and load "B" then "A" is still there. It happenes randomly.

Mixer Model: MR18

App Version: 1.0.0 (66)

Details

Commits
Restricted Diffusion Commit

Related Objects

Event Timeline

AnonymousTaskBot raised the priority of this task from to High.Nov 29 2018, 7:03 AM
AnonymousTaskBot added a project: Restricted Project.
AnonymousTaskBot added a subscriber: AnonymousTaskBot.
david closed this task as Invalid.Nov 29 2018, 7:15 AM
david added a subscriber: david.

Could not reproduce. I assume the scope was not correctly select when loading

Oscar added a subscriber: Oscar.Nov 29 2018, 7:44 AM

It happenes randomly. Full scope was selected. All settings are shared on Google drive and even loading from here didn't help. But I got my default back after loading back and forth between settings in the app.

david reopened this task as Open.Nov 29 2018, 8:20 AM

You can't load from Google drive directly - it's only for importing / exporting so this is not related to the issue itself.

So the steps to reproduce are:

  1. Save 2 settings with different layer
  2. Load first, then second
  3. Layer is still on the first

correct?
Does this also affect layouts or only layer?

david lowered the priority of this task from High to Normal.Nov 29 2018, 8:20 AM
Oscar added a comment.EditedNov 29 2018, 9:15 AM

I couldn't reproduce the issue today. I switched between 3 different settings with full scope. All different layouts and layers.

BTW the issue was with layouts and layers.

Happened again a few days ago. Default layout with a vertical row of buttons and another setting with a horizontal row of buttons. Loading default did not work, still the other setting with the horizontal buttons row. Importing default from Google drive did not work either. Deleted the horizontal button row setting and the correct Default setting was back. Switching back and forth between a 3rd layout setting does have no issues and thats a entirely different layout.

Do you have autosave enabled? It will overwrite the default. Import/export has nothing to do with the loading itself.

Have to check tomorrow. I was just loading settings, not saving. Loading default and "C" works fine but It got stuck on settings "A". Loaded default and still had the settings of "A". Importing default from Google drive and saving did not help. Deleting settings "A" helped.

Oscar added a comment.Dec 17 2018, 6:44 PM

I've sended screen recordings to you.

david added a comment.EditedDec 24 2018, 8:37 AM

Do you have autosave enabled?

If so then this is the expected behavior as the current settings will be stored as "default".

No autosave is Off as shown in the screen recordings I' ve sended you.
I have also a new video, I'll send it to you.

Sended you the video that shows the bug . Sended you also the app settings wich are saved in Google drive.
Xair pro 1.0.0 (71)

david renamed this task from app settings to Autosave always enabled.Dec 25 2018, 11:24 AM
david updated the task description. (Show Details)
AnonymousTaskBot mentioned this in V1.0.2.
AnonymousTaskBot mentioned this in V1.0.1.
AnonymousTaskBot mentioned this in V1.0-12.
david closed this task as Resolved by committing Restricted Diffusion Commit.Dec 25 2018, 11:35 AM
david added a commit: Restricted Diffusion Commit.