Page MenuHomePhabricator

Mix Station Pro - Service has been stopped by the OS
Closed, WontfixPublic

Description

Mix Station Pro - Service has been stopped by the OS

Whenever the screen switches off, on re-activating the screen the message "Service has been stopped by the OS" is displayed and I have to reconnect to the mixer again.

This was not an issue until the completely new architecture version.

This issue can be reproduced in off line mode.

Phone: Nokia 8 running Android version 9

Activated the Write logs option in the Developer section.
1554506601001 INFO: [ActivityAppSystemSetup] Logging activated
1554506602993 INFO: [GActivityStack] Removing current and pop item
1554506602994 INFO: [GActivityStack] Returning current
1554506602995 INFO: [MSApp] Going back to 1
1554506603008 INFO: [MSApp] Changing activity to 1
1554506603008 INFO: [GActivityStack] Clear stack (add)
1554506603008 INFO: [GActivityStack] New stack item: 1
1554506603009 INFO: [GActivityStack] Current stack: 1,
1554506604166 INFO: [MSApp] Changing activity to 6
1554506604167 INFO: [GActivityStack] Clear top
1554506604167 INFO: [GActivityStack] Id of activity not found in stack: 6 - stack not cleaned
1554506604167 INFO: [GActivityStack] New stack item: 6
1554506604168 INFO: [GActivityStack] Current stack: 1, 6,
1554506607375 SEVERE: [MSApp] Changing to null activity
1554506611104 INFO: [MSApp] Changing activity to 1
1554506611104 INFO: [GActivityStack] Clear top
1554506611104 INFO: [GActivityStack] New stack item: 1
1554506611105 INFO: [GActivityStack] Current stack: 1,
1554506611129 INFO: [MSApp] Changing activity to 1
1554506611129 INFO: [GActivityStack] Clear top
1554506611129 INFO: [GActivityStack] New stack item: 1
1554506611129 INFO: [GActivityStack] Current stack: 1,
1554506615736 SEVERE: [MSApp] Changing to null activity
1554506799908 INFO: [MSApp] Changing activity to 6
1554506799909 INFO: [GActivityStack] Clear top
1554506799909 INFO: [GActivityStack] Id of activity not found in stack: 6 - stack not cleaned
1554506799909 INFO: [GActivityStack] New stack item: 6
1554506799909 INFO: [GActivityStack] Current stack: 1, 6,
1554506809750 SEVERE: [MSApp] Changing to null activity
1554506811705 INFO: [MSApp] Changing activity to 1
1554506811705 INFO: [GActivityStack] Clear top
1554506811705 INFO: [GActivityStack] New stack item: 1
1554506811705 INFO: [GActivityStack] Current stack: 1,
1554506815254 INFO: [MSApp] Changing activity to 6
1554506815254 INFO: [GActivityStack] Clear top
1554506815254 INFO: [GActivityStack] Id of activity not found in stack: 6 - stack not cleaned
1554506815254 INFO: [GActivityStack] New stack item: 6
1554506815254 INFO: [GActivityStack] Current stack: 1, 6,
1554506819393 INFO: [MSApp] Changing activity to 8
1554506819394 INFO: [GActivityStack] New stack item: 8
1554506819394 INFO: [GActivityStack] Current stack: 1, 6, 8,
1554506824247 INFO: [MSApp] Changing activity to 11
1554506824247 INFO: [GActivityStack] Replacing current with new activity
1554506824248 INFO: [GActivityStack] New stack item: 11
1554506824248 INFO: [GActivityStack] Current stack: 1, 6, 11,
1554506825957 INFO: [GActivityStack] Removing current and pop item
1554506825958 INFO: [GActivityStack] Returning current
1554506825958 INFO: [MSApp] Going back to 6
1554506825959 INFO: [MSApp] Changing activity to 6
1554506825959 INFO: [GActivityStack] Clear top
1554506825959 INFO: [GActivityStack] Id of activity not found in stack: 6 - stack not cleaned
1554506825959 INFO: [GActivityStack] New stack item: 6
1554506825960 INFO: [GActivityStack] Current stack: 1, 6,
1554506828568 SEVERE: [MSApp] Changing to null activity
1554506830284 INFO: [MSApp] Changing activity to 1
1554506830285 INFO: [GActivityStack] Clear top
1554506830285 INFO: [GActivityStack] New stack item: 1
1554506830285 INFO: [GActivityStack] Current stack: 1,
1554506830302 INFO: [MSApp] Changing activity to 1
1554506830302 INFO: [GActivityStack] Clear top
1554506830302 INFO: [GActivityStack] New stack item: 1
1554506830302 INFO: [GActivityStack] Current stack: 1,
1554506832815 INFO: [MSApp] No previous activity on stack - closing app
1554506832832 SEVERE: [MSApp] Changing to null activity

Mixer Model: X32

App Version: 1.0.01 (272)

Event Timeline

david added a subscriber: david.Apr 6 2019, 7:09 AM

This means that the OS is killing the background service. There could be various reasons, mostly "power saving" apps, antivirus apps could be the reason.

david closed this task as Wontfix.Apr 17 2019, 2:02 PM
david claimed this task.

Could not find the root cause - as it only seem to occur on once device I'll close this for now as device related issue