Page MenuHomePhabricator

Button with multiple actions not working
Closed, InvalidPublic

Description

Hi David,

in the version 1.x a button stops working when it has multiple actions and one action is already fulfilled. In version 0.066.0 that worked.
Example:
Button with actions:

  1. select layer
  2. open layout

If the layer is already active the button will simply do nothing. If another layer is open the button works properly.
When the order of the actions is switched and the layer is already active the layout will open but all following actions will not be processed.

Regards,
Tim

Event Timeline

Teiko created this task.Sun, Jun 9, 3:18 PM
Teiko created this object in space S1 Public.
Teiko added a project: Mixing Station Core.
david added a subscriber: david.Sun, Jun 9, 10:04 PM

Changing the view does destroy all the UI items and associated actions since the view has been changes.
Therefore the open view action should always be used at the end of the list.

I could not reproduce your issue. Is the button disabled or enabled when the layer is already selected?

david closed this task as Invalid.Thu, Jun 13, 9:02 AM