Page MenuHomePhabricator

MS Pro, iOS, disconnects on screen lock
Closed, WontfixPublic

Description

Hi.

I've been beta testing the iOS version of MS, and now bought the Pro (non-beta) version. Loving using it. You've done a great job.

But on my iPad as soon as the device goes to the lock screen (so as to blank the screen and save battery), MS disconnects - or rather, when it comes out of the lock screen MS has to reconnect.

I've spent a bit seeing if it's an iOS/setup problem that I can deal with. Nothing found as yet. But, it seems an app has to be set for "background refresh" to access WiFi when in the lock screen. My iPad is set to enable background refresh, but MS does not appear on the list of apps registered to use it. So, I'm wondering if this may be my issue.

Your thoughts would be most welcome.

By the way, the issue is made worse by the need to re-select my custom layer after reconnection.

All the best,
Richard.

Mixer Model: X32R

App Version: Up-to-date (not with the iPad at the moment)

Event Timeline

david closed this task as Wontfix.Jun 11 2019, 6:38 PM
david claimed this task.
david added a subscriber: david.

Expected behavior - iOS terminates any ongoing connenctions when the screen turns off.