Page MenuHomePhabricator

GUI hang while connected to XTouch compact
Closed, ResolvedPublic

Description

Hi David, I'm mapping an XTouch compact to MS-XM32 on a Samsung Tab A with considerable success.
I'm noticing that the screen freezes from time to time, only while connected to the controller. The touch surface continues to function but the screen does not update until a MIDI message (any) comes from the controller. This is persistently happening in the channel EQ page, when adjusting the EQ from the screen, about 2 seconds after initial touch. This is also fairly common in the MIDI assignments and Layout/Layers file management pages but not persistent in the same way. I have not noticed this glitch on any other pages besides those.

I've ordered a cable to connect my iPad to see if the issue happens there.
Thanks for the continued support
David

Event Timeline

david added a subscriber: david.Aug 30 2019, 6:09 PM

This seems to only occur on Samsung Tab A devices. The current assumption is that it's a OS/driver related issue as all other devices work fine

david added a comment.Oct 1 2019, 7:32 AM

Seems like it's related to android 8 somehow

david added a comment.Oct 1 2019, 11:17 AM

Issue is reproducable in a certain android environment with certain usb midi devices connected. Not sure what the root cause is yet

AnonymousTaskBot mentioned this in v1.0.10.
AnonymousTaskBot mentioned this in v1.0.9.
AnonymousTaskBot mentioned this in v1.0.8.
AnonymousTaskBot mentioned this in v1.0.7.
AnonymousTaskBot mentioned this in v1.0.7.
AnonymousTaskBot mentioned this in v1.0.9.
AnonymousTaskBot mentioned this in v0.5.4.
david closed this task as Resolved.Oct 1 2019, 2:03 PM