Page MenuHomePhabricator

Midi partially broken on OSX
Open, LowPublic

Description

OSX 10.14.6 layout import breaks MIDI input on X32
1 Open MSP, X32, Offline, MIDI works both ways.
2 Edit Layouts, load default, MIDI only goes to the controller.
3 Edit Layouts, load default, MSP crashes.

Event Timeline

nottooloud created this object in space S1 Public.
nottooloud added a project: Restricted Project.

Same on 10.13. No problem if MIDI controller isn't connected.

nottooloud updated the task description. (Show Details)Sep 15 2019, 9:11 PM

Disconnecting from a mixer and coming back to it also kills MIDI input. Disconnecting again crashes MSP.

Might be related, closing MSP via the window corner red X icon frequently beachballs it with a MIDI controller connected.
Doesn't seem to be a problem without a controller.
Quitting with the taskbar icon always works.

That was all with MIDI Fighter Twister as the controller.
Novation LaunchControl on the same template loses input on load, but MSP doesn't crash on 2nd load.
MSP does beachball on red X icon quit.

same as T1607.

I found a workaround, which is to load, save as default, and then restart the app.

david added a subscriber: david.Sep 23 2019, 3:44 PM

I could not reproduce this so far. Which scope did you use when loading the default settings?

Steps I did:

  1. Create midi config
  2. Save as default
  3. Load other settings randomly
  4. Load default

Midi still works

XR18, Macbook Air running 10.14.6, MSP 0.0.3(12), MIDI Fighter Twister or Behringer BCR or Novation Launch Control.
Search, connect, MIDI works.
Settings, MIDI, Folder, Default, Load, either full scope or just MIDI, MIDI doesn't send to MSP.
Settings, MIDI, Edit, Twister still shows as connected.
MSP still sends data to Twister or BCR.
Setting MIDI, folder, default, Load, MSP beachball crashes if Twister or Launch Control connected, not if BCR.
I just sent a couple fresh crash logs to Apple.
If I load default without the MIDI scope, everything is fine.

I am attaching the full scope .msz. Perhaps you can see something in there.

By the way, (12) is not adding extensions yet. Should it be?

david added a comment.Sep 23 2019, 4:50 PM

I just sent a couple fresh crash logs to Apple.

I can't see those as the app is distributed outside of the app store.
Usually it's enough to just start the app with a internet connection and it will submit the logs to my server.

Ah yes it should. I'll take a look at it

david added a comment.Sep 23 2019, 4:53 PM

From the logs it looks like the app is crashing because of an invalid configuration. The source value (Param A/B) for at least one controller has an invalid value

You're seeing that in crash logs dated just now? I definitely had bad data in my BCR config, but it wouldn't even load, and that was Saturday.
The issue was with the Learn function on a knob that is also a pushbutton. You have to be really careful not to turn it while or after pushing.

I'll look through the Twister config.

I'm also seeing a beachball crash by trying to close the app with the red X corner icon.

I just created a new Twister config. Just 1 knob, Channel 1 fader w/ SOF.
Works.
Save as default.
Load default.
Doesn't work.
Load again, still doesn't work, but no crash, so there is something hinky in my big Twister config.
But that's not why the MIDI stops working.

david added a comment.Sep 23 2019, 5:26 PM

That's really strange. I've did the same thing with a simple pad controller and/or bfc2000 and didn't had this issue so far.

What controller are you using that works?

david added a comment.Sep 23 2019, 5:30 PM

I have a BFC2000, PreSonus Fader Port, and Steinberg CMC-PD

Another data point is that it works on Windows and on iPad.

Same behavior on a 2009 Macbook 10.11.6,

Perhaps there's some setting I'm changing in an unanticipated way.
Here's an X18 folder.

The name of this one should probably be changed, since it's not about layout import, it's about MIDI controllers.
OSX 0.0.4(16) now has a Quit menu item. Works fine without a MIDI controller.
However, if I have a controller plugged in and I open a mixer, either offline or connected, the Quit menu item beachballs MSP.

david added a comment.Oct 9 2019, 5:54 PM

This should be fixed in the latest version, can you verify that?

No change on 0.0.4(17), Qu32 and LaunchControl.

In the interest of eliminating any corrupted configs or whatever at my end, I dug in a little harder.
I uninstalled MSP, deleted everything in the MixingStation folder except the licenses, emptied the trash, and rebooted.
I installed 0.0.4(17), and searched my Qu32.
I went straight to App Settings and enabled MIDI.
I went to MIDI, added New device LaunchControl.
I went to Add Controller, and made Fader-1 control the Ch1 main fader.
I backed out and verified that that worked.
I went to Layouts and saved one called default.
Checked that MIDI still works.
I loaded default.
MIDI doesn't work.
Quit the app to a beachball.
I think I can safely say it's nothing special about my install.

david added a comment.Oct 11 2019, 7:05 PM

I'll try to reproduce it tomorrow with the same steps

Could it be a conflict with another java interpreter? I think Macs are pretty immune to that sort of issue, but I don't really know how any of this works.

david added a comment.Oct 11 2019, 7:11 PM

No the laucher always uses the bundled jre, this shouldn't be an issue

david added a comment.Oct 14 2019, 6:01 PM

I could reproduce the issue

david added a comment.Oct 14 2019, 6:33 PM

It seems like the issue is a bug inside the java runtime itself on osx - not sure yet how to fix it

Report it to them and go about your day? We have a workaround.

david added a comment.Oct 14 2019, 7:11 PM

Yup, but it still freezes the whole process when closing.

david added a comment.Oct 14 2019, 9:00 PM

Waiting for a reply from oracle
9062526

david renamed this task from OSX layout import to Midi partially broken on OSX.Oct 14 2019, 9:02 PM
david triaged this task as Low priority.

That looks familiar.