Page MenuHomePhabricator

Not all dSnake settings synced
Closed, ResolvedPublic

Description

tl/dr MSP isn't reading gains from stagebox channels above #35.

Troubleshooting this one was fun. Qu32 to AR2412 to AB168. I usually put the AB168 upstage, but patch it in the low channels. I just built a scene on the board. When I open MSP, CH12-16 all show gain 5, which should be 28. They're patched to Expander 12-16. I reset all the gains to see if I could figure out what it was reading where. CH32 is local, and I set its gain to 60. I set the gains on Ch1-31 to the values 1-40, matching the stagebox channel they were patched to. In order to do that, I had to pad the first 4. This uncovered another bug, which I am also posting. Since the channels I noticed were displaying 5, I set the stagebox 5 channel to padded 5, in order to differentiate it. I saved that scene, quit MSP, and reopened MSP. All channels displayed as expected, except 12-16, which displayed 5. I also noticed that they didn't show phantom power on, although it was. It looks like MSP is not loading preamp data for those 5 channels. I went back through some older scenes. Another missed Extender 12-16. 1 loaded every channel except 12, which was patched to Extender 12. Extender 13-16 weren't used.

So, in summary, I don't think MSP is getting preamp data from Extender channels 12-16, which correspond to channels 36-40 in a straight patch. If I patch those preamps someplace else, the bug follows them.

I am pretty sure I've gotten bit by this one on my GLD, too, but I didn't have time to dig into it.

Related Objects

Event Timeline

nottooloud created this object in space S1 Public.
david added a subscriber: david.Dec 23 2019, 2:55 PM

Do you know if this also happens when the extender is directly connected to the mixer?

Interesting question. I'll have those components together on New Year's Eve. I'll try to remember to check.

I forgot, Qu doesn’t have an Extender port like GLD. AB168 or AR2412 work normally on DSnake port. I'll check the AB168 on my GLD Extender port when I get the chance.

david added a comment.Wed, Jan 1, 11:00 AM

ah yes I just thought the issue might happen if the extender is directly connected to the dSnake port.
On the gld it should work fine

Is there something else I can try to help you troubleshoot this?

david added a comment.Fri, Jan 10, 6:19 PM

I don't think so. I just have to find some time to setup the mixer with stageboxes to fully test it

david changed the task status from Open to Confirmed.EditedSat, Jan 11, 3:18 PM

I could confirm the issue, all expander gains are at +5dB instead of the actual value

david added a comment.Sat, Jan 11, 3:23 PM

Update: The issue is the sync, the values update correctly once touched at the mixer

david renamed this task from Qu32 online stagebox gains Extender 12-16 to Not all dSnake settings synced.Sat, Jan 11, 3:40 PM
david closed this task as Resolved.Wed, Jan 15, 7:12 AM
david claimed this task.