Page MenuHomePhabricator

no properly termination of Mixingstation on MAC OSX
Closed, InvalidPublic

Description

Mixing Station on MAC OSX is working properly. But when i want to quit the app, it will not quit completley. When open the Force Quit Application, i see the application "mixing station" is hanging with "no response from mixing station".

Platform: OSX
Variant: XM32
Version: 10.14.6

Event Timeline

What version app and OS? Version 0.0.8(42) quits normally on 10.14.6 and 10.13.6 for me.

david added a subscriber: david.Feb 3 2020, 4:48 PM

I contacted him and it's the latest version (42)

david closed this task as Invalid.Feb 5 2020, 5:27 PM

Could not reproduce as well

I've run into now. Both times were on a closed network, so it might have something to do with MSP phoning home. I'm also seeing really slow program starts on closed networks.

david added a comment.Feb 9 2020, 4:12 PM

It only checks for updates and / or tries to send crash reports in the background. It shouldn't affect startup performance since it's a background task.
But that's a good hint. Maybe the app was still trying to send a crash report while being closed.

Connectivity is definitely part of the issue.
MSP 0.1.0(45), Mojave 10.14.6
Mixer and laptop on isolated wifi.
Quit app, beachball.
Without doing anything else, I switched the laptop to connected wifi.
App closed itself.

No problem on either Win10 PC.