Page MenuHomePhabricator

Win10 update crash
Closed, ResolvedPublic

Description

Last two updates, from 0.0.9(43) to 0.0.9(44), and then from 0.0.9(44) to 0.1.0(45) have crashed on updating on one of my Win10 computers. Windows crash reopen query fails to launch. Opening from my desktop icon, however, works, and shows that the update succeeded. Appears normal after that. Works fine on another Win10 computer.

Revisions and Commits

Event Timeline

nottooloud created this object in space S1 Public.
david added a subscriber: david.Feb 14 2020, 7:14 PM

I don't have this issue. When does the crash occur? After the app has completed the download?

Yes, the download completes and the app has actually been updated.
Only happens on one of my two WIN10 machines.
No crash reports showing up at your end?

No crash reports on my end

david added a comment.Mar 4 2020, 7:21 AM

Is this still happening?

Self update from 0.1.1(46) to 0.1.2(47), crash.
Restart dialogue confirm, crash. Repeat.
0.1.2(47) then appears to run fine from new start.
I just did a manual install of 0.1.2(47), maybe that will fix it.

OSX is on 0.1.3(50)? I assumed they kept parity.
I'd still like to see version numbers on the download page.

david added a comment.Mar 4 2020, 3:55 PM

The versions are the same for all platforms. Maybe you've selected beta for osx?

Ah, yes. I hadn't selected beta on the PC.
0.1.3(50) crashed on update.

david added a comment.Mar 16 2020, 2:55 PM

Hm so far I don't know what the issue is. The latest version has some extended error logging. Can you provide a screenshot of the crash when an update is available again?

Is that 0.1.3(51), or the one after?

david added a comment.Mar 16 2020, 7:13 PM

That's the current one. The next update will follow soon, then you should see more error details

Can you post somewhere when it updates?

Thought I had it when I discovered I had two versions installed. Windows baffles me these days.

Uninstalled, reinstalled (47), crash on update to (51).
Screen snip.

david added a comment.Mar 21 2020, 7:45 PM

This comes after the update? Like when it's restarting the updated version?

Yes. And if I click Yes in that box, it crashes again. If I start the app cold, it has been updated and works fine.

Crash report going to 0.1.4(52) is 1 character different.

Here's the file from the directory.

Thanks, that should be enough for me to try and fix this. I'm not yet sure what could be the root cause but it bumps me into the right direction.

Just fired up the W10 crashy machine for the first time in a while. 0.1.4(52) to (55) crash.

david closed this task as Resolved by committing Restricted Diffusion Commit.Apr 16 2020, 1:59 PM
david claimed this task.
david added a commit: Restricted Diffusion Commit.

Opened 0.1.4(55), got the update notification to 0.2.0(56).
Update proceeded and closed silently.
App won't open.
Downloaded and installed 0.2.0(56).
App won't open.
Reboot.
App won't open.
Control Panel|Programs and Features|Uninstall or change a program shows 2 Mixing Stations, different sizes and dates.
Deleted both.
Reinstalling, and noticed it's going into C:\Users\(username)\AppData\Local\mixing-station-pc
Shouldn't it be in Applications?
Still won't open.

david added a comment.Apr 18 2020, 6:39 PM

I think I've goofed up 2.0

Ah, maybe, doesn't look like it's running on the Mac now.

david added a comment.Apr 18 2020, 7:23 PM

You can redownload the app now. The first release of 0.2.0 was simply broken, sorry about that

Reinstalled 0.1.4(52), being the most recent working one I'd archived.
Update to 0.2.0(58), sadly, crashed.
Closing and reopening works.