Page MenuHomePhabricator

SQ SOF incorrect assigns
Closed, ResolvedPublic

Description

Finally got an SQ6. Set it up as 8 Mixes 4 Groups.
In Mixing Station, SOF Mixes 1-8 work.
However, SOF Groups 1-4 select Mixes 5-8, SOF FX 1-4 select Groups 1-4, and SOF MTX 1-3 select Groups 5-8.
SQ firmware 1.5.1

Platform: OSX
Variant: SQ
Version: 1.0.4 (118)

Revisions and Commits

Event Timeline

The old SOF picker works correctly.

{{userId:11}}

So this only happens with the sof list UI element?

{{userId:1}}

Did you change the mix/group configuration of the mixer before or after connecting?
It could be that the app didn't pickup the mixer config change.
I just checked with 4 groups and 8 mixes and the app does select SoF correctly.
Were the mixes/groups all mono or stereo?

{{userId:1}}

All 8 mixes were mono, all 4 groups stereo. The issue is with custom buttons, not the old picker item. Mixer configuration was made first. App remains incorrect on repeated reconnects. The groups don't start until SOF 13, which is marked FX1 in layout item setup in my case. SOF 13-24 appear go to groups 1-12. Since I can only access the mislabeled 1-19, I can't get to the FX and the matrices.

Started over, fresh layout. Mixing Station 1.0.4(119)
Add a button with action SoF 1, labeled
Mix 1
[label]
[sofname]
Cloned it several times, and replaced the first label line with the name shown in the edit action picker as follows:
Group 1 with SoF 9
FxSnd 1 with SoF 13
Mtx 1 with SoF 17
Mtx 3 with SoF 19, the last entry in the picker list.
The edit action picker list matches the board configuration: 8 mixes, 4 groups, 4 FX, 3 matrices.
The Mix 1 button activates Mix 1.
The Group 1 button activates nonexistent Mix 9.
The FxSnd button activates Group 1.
The Mtx buttons activate nonexistent Groups 5 & 7.
The [label} on the buttons confirms the SoF number being set.
The [sofname] displayed on the button matches the incorrect activations.
Also confirmed in the old SoF picker, which works correctly, and on the mixer.
Layout attached.

Interesting data point. I loaded an old template I made when I was about to mix on my first SQ. I had included buttons for 12 Mixes and 12 groups, along with the usual 4 FX and 3 matrices, because I didn't know how the mixer might be configured. It works, sort of. Mixes 1-8 select the same mixes as the SOFList item. Mixes 9-12 do nothing. Groups 1-4 also work correctly, and 5-12 do nothing. FX and matrices also work, except the buttons say [sofname]. Here's where it gets odd. If I edit open the FX 1 button, it says it's using S0F 25. If I click on that, "Off" is highlighted. Close the picker window, and now it's using S0F 0. Close the editor, and the button doesn't work.

{{userId:11}}

Hmm. I don't see a file upload here any more, and repeated attempts to use the Community upload failed.

{{userId:11}}

Ah yes that could be because of how the sq stereo/mono and mixer configuration works. I'll take a look at the SoF action, maybe it's a simple fix.

What error do you get when uploading to community?

{{userId:1}}

Error was "No settings uploaded, use the application to upload settings."

I was sending from Mixing Station on a Mac, which sent me to my browser after the login screen, and that's where the error showed up.

I don't think it has anything to do with mono/stereo. I think your send action editor list is numbering consecutively, when it needs to leave spaces for the sends that don't exist. My layout that already had higher numbers works, but they aren't available in the action edit list. Whatever array is populating [sofname] is only filling the 1st 19 slots, mixes 1-12 and groups 1-7, which is how many sends there are total.

{{userId:11}}

The next update will change the behavior. The app didn't remove the disabled/not used mixes.
The channel actions will now always show 12 target mixes.
Depending on the mixer config the first items will be the mixes, followed by the groups.
So item 1 will be mix 1 (if at least 1 aux) or group 1 (if no auxes are configured)

{{userId:1}}

david closed this task as Resolved by committing Restricted Diffusion Commit.Dec 18 2020, 10:33 AM
david added a commit: Restricted Diffusion Commit.

Brilliant, thanks.