Page MenuHomePhabricator

Midi MCU meters are not following midi scroll layer
Closed, ResolvedPublic

Description

the meters on my midi control surface are allways showing channels 1-8 from the actual layer. if i scroll through the layer, the meters are not following

Platform: Windows
Variant: XM32
Version: 1.1.0 (125)

Event Timeline

I could not reproduce this issue so far. Did you modify the midi settings or is it stock mcu?

{{userId:1}}

i just added a midi device with mcu and connected to the midi-ports. scrollong through the channels is working, the display is following...just not the meters

{{userId:34}}

btw: in the stock mcu, the actions of the buttons ch prev and ch next are reversed, prev scrolls to the right, nenext to the left

{{userId:34}}

for me, it looks like the same problem we had it a few months ago with the select button who was not following the layer scroll.
solved in ticket 2314 https://dev-core.org/mixing-station/tasks/2314

{{userId:34}}

just found someone else on facebook who has the same behavior on a x-touch

{{userId:34}}

AnonymousTaskBot changed the task status from Open to Confirmed.Jan 10 2021, 11:18 AM
AnonymousTaskBot mentioned this in v1.4.1.
AnonymousTaskBot mentioned this in v1.1.0.
AnonymousTaskBot mentioned this in v1.2.0.
AnonymousTaskBot mentioned this in v1.2.0.
AnonymousTaskBot mentioned this in v1.2.0.
AnonymousTaskBot mentioned this in v1.2.0.
AnonymousTaskBot mentioned this in v1.2.0.
AnonymousTaskBot mentioned this in v1.2.0.

The latest beta (from today) should fix the scrolling issues

{{userId:1}}

Yes, the Meters are now working as expected. thanks for the fast fix!

{{userId:34}}