Page MenuHomePhabricator

Menu disappears after snapshot load
Closed, WontfixPublic

Description

Click on the folder icon. Load new snapshot. Go back to mixer view, and the menu (FX, Meters, etc) is not there. Have to close the app and re-open to get the menu back.

Mixer Model: XR18

App Version: 0.002 (2)

Event Timeline

AnonymousTaskBot raised the priority of this task from to High.Jul 21 2016, 8:00 PM
AnonymousTaskBot added a project: Restricted Project.
AnonymousTaskBot added a subscriber: AnonymousTaskBot.
david lowered the priority of this task from High to Normal.Jul 22 2016, 1:31 PM
david closed this task as Wontfix.Jul 27 2016, 12:53 PM
david claimed this task.
david added a subscriber: david.

Could not reproduce the issue on any device. No idea what could cause this issue as drawing the manu is handled by android.

BrianC added a subscriber: BrianC.EditedAug 3 2016, 1:53 AM

I can duplicate this issue very easily, in Full screen and Normal viewing mode, and it is NOT necessary to close the app to restore the top menu. By swapping to another task in Android, then back to Mixing Station, the menu is restored.

MS 0.000.4 Pro beta. Android 4.4.2 on Samsung SM-T320 hardware. XR18 w/latest FW.

Same everything except using Samsung Galaxy 6S and Android 6.01. Same issue.

Both of these devices have high resolution displays.

This occurs every time after a snapshot is loaded. Tried all development mode options related to screen draws, GPU, etc. with no difference.

So there is a workaround, but it would be great if this could be somehow "fixed" going forward. Maybe the task swap clue can help? Maybe there's overlap between buttons causing a redraw issue on some hardware? A beta with the buttons spaced apart might be worthwhile.