Page MenuHomePhabricator

Crash when touching not assignable knob
Closed, ResolvedPublic

Description

App falls down when you touch custom aux send buttons on user buttons strip on US channel. Yes, the AUD SEND buttons are not supposed to be there but if you go to overview and switch to next US with prev/nxt arrow and return back to overview its there. Touch it and XM32 falls down.

Mixer Model: X32c

App Version: The latest

Details

Commits
Restricted Diffusion Commit

Related Objects

Event Timeline

AnonymousTaskBot raised the priority of this task from to Normal.Oct 1 2016, 12:17 AM
AnonymousTaskBot added a subscriber: AnonymousTaskBot.
safa added a subscriber: safa.EditedOct 1 2016, 3:30 PM

Pardon the typos, I wrote the bug report from my mobilephone and the Phabricator bug tracker is obviously not optimized for mobilephone screen so I had to write it "blind".

Anyway here you have video "guide" so I hope it will clarify what I mean.

https://dl.dropboxusercontent.com/u/3464890/File_000.mov

PS: "US" means BUS and AUD SEND means AUX SEND :)

Safa

david added a subscriber: david.Oct 11 2016, 5:04 PM

Thanks for the detailed video! I already took a look at it but was not able to reproduce the crash.
Here is what I did:

  • Add a knob which changes the send level of bus 16
  • Select CH01
  • Select Bus01 -> Knobs gets invisible
  • Open Bus02
  • Press "Next"!
  • Go back to the mixer -> Knob stays invisible.

I also tried various different methods but could not reproduce the problem.

safa added a comment.Oct 13 2016, 11:54 PM

I reproduced the same way you described and in my case there are visible buttons and crash consequently at the end. Of course you have to go to a BUS overview/details and back to Main View ... otherwise it does not show the knobs

david added a comment.Nov 5 2016, 3:33 PM

I finally could reproduce the issue.
It only happens then the "Visibility" is set to "No SoF"

david renamed this task from App falls down to Crash when touching not assignable knob.Nov 5 2016, 3:33 PM
david updated the task description. (Show Details)
david closed this task as Resolved by committing Restricted Diffusion Commit.Nov 5 2016, 3:57 PM
david added a commit: Restricted Diffusion Commit.
safa added a comment.EditedNov 7 2016, 11:26 AM

Well, okay, but I need to have visibility on NO SoF. Anyways I can live with it... no problem.

Safa.

david added a comment.Nov 7 2016, 11:30 AM

I know, it will be fixed in V0.064.5

safa added a comment.Nov 9 2016, 2:51 PM

Nice, thanks a lot!

safa